Visit The Dirt Forum for More Information

Author Topic:   Demon Carb Jets
NJantz
Member
posted June 28, 2004 06:29 AM
are we talking gas or alky?


NJantz
Member
posted June 28, 2004 11:29 AM
running 163's in a 400" Motor

Anyone have their Demon want to run rich at idle only? Butterflies aren't open too far, idles great at 1250rpm, but sure runs you out of the shop.

Off idle (like when warming up, 1800rpm) it's beautiful.

Carb is serviced regularly, it's always done this since new.

dirtbuster
Member
posted June 28, 2004 02:54 PM
We ran 157 or 161 on a 355 and 173 or 177 on 400. Remember though a smaller motor wont necessarily take smaller jetting. Some of it depends on cam and heads and how much vacuum or pull there is on the jets.

mod4
Have you tried adjusting the idle screws to fix the rich on idle problem? Ours idled best about 7/8-1 turn out from seated. From the factory they are like 1 1/2 which will make it richer at idle.


mod4
Member
posted June 29, 2004 04:36 PM
Yeah, I've played with those, if I turn them in more then about 1 1/4 out from seated the car seems to have a stumble off idle. Since you don't race at idle, I guess I could try it.

BG/Demon like any carb company doesn't want to burn engines down, maybe I'm just being overly critical of a safely rich idle....

dirtbuster
Member
posted June 29, 2004 06:21 PM
mod4,
Have you checked to make sure your accelerator pump pasages are clear and also that there is no lash between the pump arm lever and the pump arm. If your pumps werent working right that could cause a stumble just off idle. Also ive never been around a alky engine that wouldn't run you out of the shop even if the carb was perfect.


NJantz
Member
posted June 30, 2004 06:17 AM
MOd4-
Not sure if you have explored Barry Grants site, but here is the link to their tech section. Really good info that might help diagnose your problem http://www.barrygrant.com/bgfuel/default.aspx?page=techsupport

Thanks for posting guys, I've got some 192 jet's in the car now and I've fire slotted 2 engines now. So I don't think my problem is with jetsize, could still be fuel related though. thanks.

[This message has been edited by NJantz (edited June 30, 2004).]

jws
Member
posted July 02, 2004 07:42 AM
We run gas now, but used to run Alky through our Race Demon. We got out in left field on jetting/power valve combo and were not running well. I called BG for a baseline and then proceeded to the chasis dyno. After four hours of tuning(on a 13 to 1 383) we ended up almost exactly on their baseline set up. I don't have my notebooks handy, but you can call BG for the same advice. We found about 50 hp that day. It was apparently 50 hp my claimer couldn't handle because that weekend we broke a rod and grenaded that puppy. It was runnin' like a scalded dog though!


Back to the Archives