Visit The Dirt Forum for More Information

Author Topic:   startup problems
racenmotorsports
Member
posted May 16, 2004 05:49 PM
I finally got my darn engine running. I noticed a leak coming from the front of the engine. It looks like it's coming from the front seal. Do I got to pull this thing out to fix it or what?

It sounded good too! (My first engine)
Thanks


jprads
Member
posted May 16, 2004 06:11 PM
IF ITS THE FRONT CRANK SEAL YOU CAN CHANGE IT BY TAKING OF THE DAMPER IF YOU TAKE OF THE DAMPER LOOK FOR A WEAR GROOVE IN THE DAMPER IF THERE IS IT`S PROBABLY YOUR LEAK THEN YOU CAN BUY A SLEEVE THAT GOES OVER THE DAMPER TO CURE YOUR PROBLEM


racenmotorsports
Member
posted May 16, 2004 07:38 PM
Sorry, It's the pan gasket seal


BIGDADDYBOZ
Member
posted May 16, 2004 08:38 PM
If the motor isn't very important you can clean it with carb cleaner and goob on some silicone. Other wise you'll have to pull the motor back out.


chomme
Member
posted May 16, 2004 10:18 PM
try tightening the pan bolts a little and see if the leak goes away. if it's just a small leak, you can probably live with it. just keep an eye on it. otherwise replace it with the 1 piece oil pan gaskets (all molded rubber) as chomme mentions. if you use the molded rubber, to may have to take a die grinder on some parts of it as it might hit the crank. i had to grind on mine towards the rear of the crank.


driver27
Member
posted May 17, 2004 11:14 AM
I have had good luck with Permatex "RIGHT STUFF" just clean ythe area real good with Brakleen and dry, then put a layer of sth sticky S!@# on and let it set over night.
I made a custom oil pan for a 4.3 in a Blazer "care block And could not get the gaskets to work I actually cut an inch out of each gasket and made a repair patch eith this stuff it is the S!@#. Good luck!


Back to the Archives