Visit The Dirt Forum for More Information

Author Topic:   Carb Help needed!!!!!!!!!!!!!!!!!!!!!!!
tee1up6134
Member
posted March 29, 2004 06:06 PM
OK heres the problem. My carb runs perfect only when the primary site plug on the side is out, when I put it back in the carb starts putting raw fuel out of the vents and dies. Its almost like it is getting air from that hole or something. We just did a complete rebuild kit on it and it does the same things. Any suggestions. Thanks


stockcar5
Member
posted March 29, 2004 06:40 PM
sounds to me like the bowl vent might be blocked? i also had a stuck needle and seat do this once.

luke

------------------
www.geocities.com/dirtstockcar5


racerman707
Member
posted March 29, 2004 07:04 PM
This may sound dumb but is your sight plug the stock one? Might be jamming into the float?


tee1up6134
Member
posted March 30, 2004 07:05 AM
I dont think it is touching the float but I will check. Thanks for the imput.


RangeRover
Member
posted March 30, 2004 08:49 AM
either the needle and seat are sticking or the flaot is just set wrong


tee1up6134
Member
posted April 03, 2004 10:11 AM
Problem solved, i changed the fuel cell fittng and she runs like a champ.. THANKS FOR ALL YOUR HELP!!!!!!!!!!!!!!!!!!


juliaferrell
Member
posted April 06, 2004 10:36 AM
My dear great mentor in racing always told me that when it comes to carbueration look elsewhere first. Ignition, mechanical condition of engine, and for sucking that darn air somewhere#@#@##@#@#@#@!!!!


Back to the Archives