Visit The Dirt Forum for More Information

Author Topic:   oil pressure?
chevy_20
Member
posted March 28, 2004 11:35 PM
My oil pressure light comes on right before i enter the corner. When oil is cold the gauge shows 60lbs and 40 lbs when it gets hot. Haven't had any problems till the other night. At the very end of the straight aways, the oil pressure light came on and the gauge read 20lbs. After getting into the corner...light would go off and pressure would go back up to about 40-45lbs. Is this okay? What could be causing this? Thanks


waltonjr1
Member
posted March 28, 2004 11:43 PM
Are you running a hv pump with a stock pan? If so this could be your problem.



chevy_20
Member
posted March 29, 2004 01:07 AM
hv pump with 7qt claimer pan


driver27
Member
posted March 29, 2004 10:45 AM
Also - make sure the pickup is installed to the pump properly and there aren't pinholes in the tube from someone hacking it together to make it fit a kickout pan (found out the hard way on that one - the 'pro' built 377 that had all good parts elsewhere was running the 'good' race melling 10555 pump but a cobbled together oil pickup that wasn't 'oil tight' and would suck air when the oil got below the level of the top of the tube... threw a rod trying to figure that one out... Should have replaced it when I found it cobbled together, but nobody had one in stock)

- brian

racerguy500
Member
posted March 29, 2004 04:09 PM
solid or hyrdraulic lifters? If it is solid do you have the oil restrictors in the back of the block? Without them it would act like that also.


chevy_20
Member
posted March 29, 2004 06:09 PM
I ran 5 races last year and 4 races this year with this pan and didn't have a problem till the other night. Forgot to mention....i usually run the long wix filter(can't remember #) parts store only had the short filter so i used it. Could this have anything to do with it?


chevy_20
Member
posted March 31, 2004 11:02 PM
I just pulled the pan and everything looks fine. I have about 3/8 in. clearance between pickup and bottom of pan. Any other suggestions?


nw15
Member
posted April 01, 2004 04:34 AM
what weight oil do you use


chevy_20
Member
posted April 01, 2004 07:53 AM
I run Royal Purple 41.


Ego Racing
Member
posted April 01, 2004 12:52 PM
This amy sound dumb but we have found several people who put a 7qt pan on and put 1qt in the filter and 6 in the pan and have had the same problem.


NJantz
Member
posted April 01, 2004 02:26 PM
Driver27 thanks for the suggestion of welding a nut to the oil pan to maintain clearance...I'll start doing that next time.


Back to the Archives