Visit The Dirt Forum for More Information

Author Topic:   engine hard to turn over HELP
mudslinger12
Member
posted March 21, 2004 07:59 PM
im rebuilding a 355 crank 10 under rods 20 under got all new rings and bearings clevite 77 h series bearings motor didnt need rebored was perfect now here is my problum i put in new mains crank spun like wild fire i put in 1=2=3=4 motor turned real free and when i put in #5 and #6 iit just like it locked up. so i pulled out #6 and found i had the upper and lower bearings turned around so i checked all the other rods they were all ok so i reinstalled #5 and #6 and it still turned hard so i rechecked everything and still turnes hard . ive build many motors and never had this happen what could be wrong plz help


Blackgold
Member
posted March 21, 2004 10:13 PM
I have also seen the crank turned wrong and I had 1 journial they forgot to turn and just polished it.


avila
Member
posted March 23, 2004 08:43 AM
try removing the pistion rings from #5 & #6.
Then install #5 & #6 and see if it still
is binding. Also make sure no part of the rod is hitting anywhere on the block. I'm assuming you pre oiled the bore and rings
prior to the install?


racerman707
Member
posted March 23, 2004 10:11 AM
The only way to know for sure what is going on is to take everything apart and measure everything.Measure the journals and compare them to the measurements on the rods with the bearing torqued.


mudslinger12
Member
posted March 23, 2004 06:19 PM
thanks for the replies, i haven't had a chance to get back to it yet, other than with 6 installed, i did check turning with the torque and it is 32 lbs, now i have heard that is ok....and i oiled everything, like i said, i have done many motors, and for some reason, this one seems much harder to turn, so keep the suggestions coming....


Back to the Archives