Visit The Dirt Forum for More Information

Author Topic:   350 TURBO DIAGRAMS
jhon hollomon
Member
posted November 11, 2003 01:09 AM
Does any body know where i could find a diagram on how the park mechanism works in a th-350 tranny?? thanks

------------------
Just a little crazy!!!!!!


Donnie Ross
Member
posted November 11, 2003 07:30 AM
look in a motors transmission manual at the library should have what you need


dirtracer7
Member
posted November 12, 2003 08:03 AM
What are you wanting to know. the rod moves rearward pushing the park paw to engage the teeth (if you want to call them that ) on the ring gear.

[This message has been edited by dirtracer7 (edited November 12, 2003).]

jhon hollomon
Member
posted November 12, 2003 01:16 PM
Well I honestly have never really been inside an automatic transmission and was just kinda wanting something to look at so i'm not lost when I get there. I'm gonna try to fix it while in the truck by just taking the valve body down.

------------------
Just a little crazy!!!!!!


dirtracer7
Member
posted November 13, 2003 11:59 AM
what are you trying to fix?????????? is this the truck that has rev but no fwd ?


jhon hollomon
Member
posted November 13, 2003 01:56 PM
No it has reverse. It will just roll off if you put it in park!! LOL Something quit catching in the parking mechanism. Different truck completely from my other post.

------------------
Just a little crazy!!!!!!


66jj
Member
posted November 13, 2003 02:03 PM
thats what the PARKING BRAKE is for. it should be located to the left of the other pedals..

just messing with you,,

ryan
Member
posted November 13, 2003 10:01 PM
I beleive its pretty easy to fix. Dad fixed park on my truck pretty easily when I wasn't around. I beleive there is just a little pin to hold it in park.

[This message has been edited by ryan (edited November 13, 2003).]

BrianW
Member
posted November 14, 2003 09:23 AM
Try popping off the shift cable or shift linkage, then push the lever on the trans and see if it's just a mis-adjustment - could be that the linkage isn't allowing the trans to fully go in park - easy solution and doesn't require getting "in" the tranny.... My modified with a powerglide used to do this if the linkage wasn't adjusted right.


jhon hollomon
Member
posted November 14, 2003 11:18 AM
I tried that misadjustment theory to no avail. 66jj, trust me, if this truck had a parking brake i wouldn't be as worried but after a lift kit was installed we cut all that stuff out!! LOL Kicking myself in the @ss now though!!! LOL

------------------
Just a little crazy!!!!!!


Back to the Archives