Visit The Dirt Forum for More Information

Author Topic:   Skipalator
Whitelightning
Member
posted October 19, 2003 01:38 PM
me again with another problem, but not a race car.
93 Chevy Silverado 350 engine starting skiping a little bit then gradully got worse and worse. It does ok under hard acceleration but dont want to maintain speed or rpm in one spot, exspeically at lower rpm. He is what I replaced so far with no help. New plugs, wires, cap, rotor, fuel filter, cleaned carb, checked for vacum leaks and nothing has helped. What now?


nut3d
Member
posted October 19, 2003 02:09 PM
replace your coil and 2nd ingnition coil. and see if that works


Whitelightning
Member
posted October 19, 2003 02:36 PM
where is there a 2nd coil at?


nut3d
Member
posted October 19, 2003 02:38 PM
I'm not sure of right off hand will look at school on monday


Whitelightning
Member
posted October 19, 2003 03:06 PM
I am pretty sure it only has one, lol


racer17j
Member
posted October 19, 2003 04:18 PM
does it die out or does the rpm just jump up and down on you every now and again does it do it while your setting in the driveway or only when your in gear?


tilley88
Member
posted October 19, 2003 04:45 PM
Check your distributor for excessive side to side play. My brother had a '93 with the same prob. Replaced this and that, finally took it to a mechanic friend of mine and he found it right off the bat. Experience sure helps. That's what makes The Dirt Forum so cool.


Whitelightning
Member
posted October 19, 2003 05:14 PM
when it is idling you cant hear the skip but I can see it in the rpm gauge bounceing a little, but you can be in park and rev the engine to like 2000 and try and hold it there it will fall of to like 600 rpm almost like your choking it out, go back to 2000 and do the same thing. It wont hold a steady speed or idle. But if you stand on it it will still go great.


tilley88
Member
posted October 19, 2003 06:04 PM
Sounds the same. It'll start dying on ya at idle real soon.


jay116
Member
posted October 19, 2003 06:04 PM
You might want to check your throttle position switch.
Dropping off when you hold the throttle steady is right up that things alley.

------------------
Jason Boivin
http://www.rcracing-team.com


wrenchturner10
Member
posted October 19, 2003 09:43 PM
replace the EGR cotrol solinoid, its located under the right hand side of the air cleaner, two wire connecter and two vac hoses, the problem with these is they open to fast causing a lean condition right off idle, but with moderate throttle pressure you cant feel it as bad, let us know what you find, if you take the vac hose off of the EGR valve, shoul isolate it to that source, hope this helps


dirtracer7
Member
posted October 20, 2003 07:31 AM
also pull your rotor off and check to see if the reluctor has cracks in the magnet this can cause some strange things to happen.Star shapped thing on shaft under the rotor usally cracks where the rivets are.


stockcar5
Member
posted October 21, 2003 12:50 PM
dont forget to check fuel pressure!

9-15psi is what you want on that truck.

also disconnecting the egr would be a good test to make sure the problem is not in that system.

luke

Back to the Archives