Visit The Dirt Forum for More Information

Author Topic:   MSD box and coil?
dirtracer14
Member
posted September 13, 2003 10:19 PM
Has anyone had there msd start to miss befor it went out? Last night during a restart i was hit in the rear so i jump on it just to have it pop and burp all i could do it get it off the track ...when i pulled in the infield it died but fired right back up so i went back out it ran fine for a bit with a few more pops under load... when i brought it in we replaced both the coil and msd box and ran fine..... I was wondering if anyone has had this or should i just send the box in? Will a msd box slowly go bad or start to fade?


race2j2000
Member
posted September 14, 2003 01:07 AM
i was told by msd tech that no they wont ...that they will either work or not ...you can have them tested thats what i did to mine ...i ended up finding valve train problems that seemed like electrical problems your problem could be vavle springs or bent push rods ..i would have the box checked first then possibly if the box checks out i would look at the vavle train .you shoud be able to get it checked at a speed shop that sells alot of msd stuff ....i hope this helps


SLEEPY GOMEZ
Member
posted September 14, 2003 01:00 PM
I think you have an electrical connection problem. A slightly corroded or loose connection is subject to the problem you describe as a result of impact. SLEEPY.


CNC DOC
Member
posted September 14, 2003 01:08 PM
Before replacing a battery, make sure it is fully charged and measure the voltage accross each cell. It should at least 1.8 volts. If it is less then replace the battery.


driver27
Member
posted September 15, 2003 12:44 PM
i had the same problem with mine. it ended up giving up the next day,it was a 6al. i through it out and bought a 7al2 and love it/


nut3d
Member
posted September 21, 2003 11:19 PM
can a msd box kill a coil?????. I've gone through 2 coils this year both were msd master blaster 2 coils. runnin a 6al box. I race on a high banked 3/8 mile dirt track tat is real dusty at feature time and get's rough also.


dirtracer14
Member
posted September 21, 2003 11:28 PM
I dont not use the blaster 2 coils anymore!!! i had one go out after hitting the rev chip and after rechecking the part # some of the blaster 2 coils were for STOCK ign and the other was for use in racing. Go get the blaster 3 and be done with it i put 3 hard years on my 3 wich was the one i took out.


Rick D
Member
posted September 22, 2003 12:04 PM
I have gone through a few of the MSD Coils. Same thing, the car burbs, pops... then stops. Tried the MSD Blaster 2, and the "Viberation resistant" coil, still go through two a year. Funny thing is our other car has run the same MSD coil for 4 years with no problems. Has anyone run other brand coils with their MSD Box? I have a Accel super coil or a promaster that I could stick in there instead.



driver27
Member
posted September 22, 2003 03:10 PM
I had 3 blaster 2 coils fail this year. All quit like you turned the ignition off, no intermittant problems. The longest one lasted was 5 nights. Before this I ran a Accel super coil (the big square one) with the same box, 3 years no problems. I called MSD and they suggested the high vibration coil. I have about 5 nights on one with no problems. Also I sent the three blaster 2 coils back to MSD and they replaced them! Still sucked the 3 nights they quit, but I sure appriciate MSD standing behind their product.


Back to the Archives