Visit The Dirt Forum for More Information

Author Topic:   CARB PROBLEM PLEASE HELP!!!!!!!!!!!!!!!!!!!!
tee1up6134
Member
posted March 29, 2004 06:05 PM
OK heres the problem. My carb runs perfect only when the primary site plug on the side is out, when I put it back in the carb starts putting raw fuel out of the vents and dies. Its almost like it is getting air from that hole or something. We just did a complete rebuild kit on it and it does the same things. Any suggestions. Thanks


autodoc999
Member
posted March 29, 2004 06:48 PM
what kind of carb do you have?


superdave
Member
posted March 29, 2004 08:40 PM
Is it a regular Holley sight plug? Maybe it's hitting the float if the threads are too long.


xhubby
Member
posted March 29, 2004 09:38 PM
We had exactly the same problem last year with a 4412. The carb ran great with the float plug out, but spit fuel out of the vents when the hole was plugged. Tried every thing, new fuel regulator, different carb, different intake, fuel filter, new fuel line. After spending around $200.00, & missing our practice day, we found out that the fitting to our fuel cell was bad & causing the carb to be sucking air. Spent another $20.00 on a new fitting & it was fixed. (Thanks to the help I got on this forum). CHECK YOUR FITTINGS!!!!


tee1up6134
Member
posted March 30, 2004 07:13 AM
It is a Barry Grant but I will try all these things guys. It just started doing it. But what a pain. The season is here.


driver27
Member
posted March 30, 2004 07:29 AM
Sounds like the carb is pulling a vacuum through the vent tube. Try putting a hose over your vent tube to get it away from your venturies. If it still blows fuel,check your float heights and your fuel pressure.


doug
Member
posted April 01, 2004 09:25 PM
if your floats have a hole in them it will let this hapen to. just a change the buzzard7


tee1up6134
Member
posted April 03, 2004 07:45 AM
Problem solved, i changed the fuel cell fittng and she runs like a champ.. THANKS FOR ALL YOUR HELP!!!!!!!!!!!!!!!!!!


Back to the Archives