Visit The Dirt Forum for More Information

Author Topic:   Belt drive fuel pump help Please
MOD75D
Member
posted March 25, 2004 10:10 PM
how much do you have at around 3000 rpm?? i wouldn't worry about much at idle, we run 2 to 3 lbs and 7 to 9 on the high end. does your bypass have a "pill" in it?? you might go to a smaller one. ours has a standard holley carb jet in it, size 72 i believe. the pill sets your idle pressure and the adjuster screw sets high end. hope this helps, john


MOD75D
Member
posted March 25, 2004 10:22 PM
Mod is the motor starving out for fuel? 0 pressure is 0 pressure.........at 7000 rpm if you have no pressure the motor would be shutting down, I'd geuss maybe a bad pressure gauge?


graham jackson
Member
posted March 26, 2004 06:00 AM
If the regulator is on the backend of the fuel log and returns to the tank, plug it and see if the same thing happens. If it does then it isn't the regulator. It is more likely the suction hose is getting plugged or the filter is partially plugged up.


autoshop
Member
posted March 26, 2004 12:08 PM
Make sure you have the bg belt drive reg. Totally different from the block mount pump reg. They look the same.. as in all racing parts,but there is a difference.


MOD75D
Member
posted March 27, 2004 12:59 PM
Mod make sure you set your idle pressure back down. I didn't get a chance to reply because I was sick all weekend but I was going to recamend checking that filter. I just put one of those pumps on my mod this week and it is great! The pressure is so consistant compared to the edlebrock block pump. It's nice to know that when all else fails all of us racer's do try to help each other. Good luck!


MOD75D
Member
posted March 28, 2004 08:19 AM
Thanks 44. Thats why I like the dirt forum so much. It's great that all us drivers can help one another. My problem was in the fuel filter. I guess it can be the little stuff that kills ya.LOL


Back to the Archives