Visit The Dirt Forum for More Information

Author Topic:   falcon tranny
donjuan12
Member
posted February 04, 2004 10:14 AM
Zero DITTO never had a problem getting into gear. I put never seize on the plug every time it came out and I ended up using an easy out on like the 4th or 5th time. I put a close nipple with a cap on it.
Locked the engine one night just going into the corner, the coupling busted and I drifted through the corner. With a stock trans it might have locked the rear and on a asphault 5/8 mile track that would have been the end of the car or worse it could have been the end of me.


TRM38
Member
posted February 04, 2004 12:55 PM
we ran the Falcon all last season. 60 nights. The performance is outstanding. They are strange to become acustome to. "Push on clutch to go" Bad under panick! Only probs is broken ear on housing. Not the trannys fault! Input shaft wore somewhat badly? I read the previously! Problem with the tranny? Dont know.


24KC
Member
posted February 04, 2004 05:10 PM
One year i only had to put a glide in one time and i ran 18 races. I'm in the Hott Chassis Gulf Coast region and only had one track near by to run at hence the small number of races.


Wauge28
Member
posted February 04, 2004 07:16 PM
Your a lucky one then...5 glides in one year and I gave up.


Ego Racing
Member
posted February 04, 2004 07:41 PM
I must be lucky I ran one for 3 seasons. Had an Old racer build mine, Did you guys drill a hole on the reverse hub? That was the only problem I had was welding the clutches together in the reverse pack. He drilled a hole in the hub and it never happened again.
Oh yea one other problem, he was drinking a few beers when he built one and forgot to put in the plug on the spedo cable, Trans don't work without fluid. OOPS!!


NJantz
Member
posted February 05, 2004 07:02 AM
Hey Wauge, you never called us for a glide? Im sure Dave would make a "special" one just for you. haha all you have to do is ask.