Visit The Dirt Forum for More Information

Author Topic:   bent
Whitelightning
Member
posted January 14, 2004 05:49 PM
Yall may remeber rthe other week I said it appered that my valves sounded loose and that the rocker arm nuts where put on upside down at on time bu mistake and then put back on right. Since then they backed off some and I guess that since they where installed upside down this took the self look out of the nut and aloud for them to loosen up, Well when I pulled the valve covers they were a little loose but one was extremly loose so I replaced all the rocker nuts and come to find out that the one that was so lose has a bent push rod, all other 15 check perfect so what happened any ideas? Did the valve just get to loose and the push rod jumped around and bend or do u think the push rod bent and that may be why it was loose. I just dont understand why one bent and others are fine? Basically I am wonder if this was caused by loose valve or other engine problem like turning it to hard, I turn it aboyt 6000 rpm


BIGDADDYBOZ
Member
posted January 14, 2004 07:53 PM
I would say you just had a push rod bend. 6000 isn't really turning it hard, and since it was loose for aome time it prob bounced around and started to bend before it was tightened back down.

[This message has been edited by BIGDADDYBOZ (edited January 14, 2004).]

Whitelightning
Member
posted January 14, 2004 09:31 PM
thats whats I am hoping , I will put in a new one and go from there I guess. Thanks


Raz_900
Member
posted January 15, 2004 02:50 PM
Crane Kool Nuts. $30 for the set. Since I've used them, I've never had a problem with adjustment. And, they appear to work as advertised in the cooling department..didn't have a blue/purple rocker arm all year.


Back to the Archives