Visit The Dirt Forum for More Information

Author Topic:   imca trans problems
lightning85
Member
posted May 27, 2002 02:21 AM
I WOULD LIKE TO KNOW IF ANYONE ELSE IS HAVING TROUBLE KEEPING POWERGLIDE TRANNYS IN THERE CAR IN 1 PIECE? 2 RACES 2 TRANNYS , BREAK AT FRONT PUMP . HAS REAR MOUNT.


andykmod
Member
posted May 27, 2002 02:55 AM
Make sure your drive shaft is not bent and also make sure you have a-little slop between the drive flange and the drive plate on the crank------should be about a 1/8 inch or so. I usually get about 25 nights out of mine but i change fluid every 2 weeks and change filter/fluid every 4 seems to be a good deal also try not to over (bite)the car good luck !!!!!! Who builds them make sure they know what they are doing.


Donnie Ross
Member
posted May 27, 2002 06:31 AM
you said rear mount, do you mean to the chassis or a brace coming from the bell? a solid rear mount with motor plates will bust it every time I use motor plate with tranny hanging off engine never a problem broke a couple of cases with rear mounts.Burt Brown
AkA (Powerglides on here) has a bracket he uses from bell to rear of tranny wich should work well.Good Luck


jlfastride
Member
posted May 27, 2002 10:25 AM
i also have a brace that bolts up around the bellhousing bolts with threaded rods that run down to a peice of angle that is bolted to where the rear mt would be. i don't overtighten them just snug to help support the case and to keep it in the car if it should break. gl


bbracer17
Member
posted May 27, 2002 06:41 PM
I made a bracket similar to what fastride is describing and it works well .


Back to the Archives