Visit The Dirt Forum for More Information

Author Topic:   Handling ?
34Racing
Member
posted May 19, 2002 05:25 PM
what kind of shocks do you have?are the bushings in the front control arms stock rubber or poly?


EVANSRACING24E
Member
posted May 19, 2002 10:56 PM
what pressures are you running in the tires and what size are they. i had the same basic setup last year.


34Racing
Member
posted May 21, 2002 08:00 PM
34 i ran 20 rf 18 rr and lr and 14 lf. i also ran the same shocks as you and it didnt feel like it rolled over. i never had a problem with the tires rolling either but i like driving deep in the corners that is why my front is a little higher . another thing you might try is a 1350 on the rf and see if that takes some of it out. i tried it but it didnt fit my driving style. also check your bushings up front like in marples post.


34Racing
Member
posted May 22, 2002 08:21 PM
look to see if the rubber is pushing out excessively, weather cracked real bad or pieces missing. that is a sure sign that they are bad and being orginal equipment they are probably worn.


dirtracers
Member
posted May 24, 2002 10:47 PM
In my car the bushings were so wore out you could pull the top of the tire and the whole A arm moved we put new bushings but it was a paine in the ****


marple
Member
posted May 24, 2002 11:21 PM
them bushings are gonna be the trick.looks like you got the right #'s


34Racing
Member
posted May 26, 2002 05:57 PM
yes it will 34. that is also alot of the handling problem. sorry i didnt notice that before but i would try to get the % up to aleast 53 to start with on the rear.


Flatlander
Member
posted May 26, 2002 10:24 PM
are you sure those springs rates acurate how much brake you using to set it up do you use both feet or just the right foot


34Racing
Member
posted May 27, 2002 03:27 PM
Hey Evans the car is already 100# over weight. Should I just add weight to get the right % and not worry how much over the car weighs?

Flatlander the spring rates are accurate and I use both feet when driving. I don't use very much brake at all just enough to set the car. The track is a 3/8 mile high banked very fast track.

Thanks for the help.

Back to the Archives