Visit The Dirt Forum for More Information

Author Topic:   Help on water pump
Dirt-Tracker
Member
posted August 26, 2002 09:41 PM
I run a 347 ford stroker. This weekend the car started getting hot. I pulled into pits and there was hardly any water in radiator. My over flow was completely full. Got back home filled up radiator with water and cant get any circulation. Water in block got about 170 at home when water in radiator is cold. When I have cap off radiator cant see any circulation. It does kinda have a little bubbling, like a bad head gasket. We decided to run a compression check on engine. Every cylinder hits 120 psi on first compression stroke then builds to 175 to 180 on the next 4 strokes and stays steady there with no leak off. To me that tells us we dont have a head gasket problem.
The water pump is new this year and looks fine. Rotates well and impellers look good. My dad says he has seen alot of water pumps that are bad but look fine. Any thing else to check before I order new water pump?
Almost forgot.......we flushed radiator, it isnt clogged, after we took pump off we ran water through both water ports and the water runs through with no restriction. HELP!!!!


chief4car
Member
posted August 26, 2002 09:48 PM
It coutld be possible that you lower hose is colapsing, have you checked this.

It sounds like the water pump may have shot craps though.

Jim

6pack
Member
posted August 27, 2002 08:51 AM
Ive never seen them collapse at idle only at high rpm. I dont run a thermostat, we ripped the guts out of a thermostat and use as a restrictor. I did stick a water hose down the neck and force water through with no problem.
I ordered a new pump today.....hope that fixes it.


Back to the Archives