Visit The Dirt Forum for More Information

Author Topic:   If it wasn't for bad luck I wouldn't have any at all(Oil Pressure)
ryan
Member
posted April 13, 2002 05:28 PM
Just about ready to load the car for the first race looked at the gauges it was around 25 it would go from 10-25psi. We shut it down and restarted it and it started out a 65 then dropped straight to 25 .First I put a different gauge on no change, different filter no change, different oil filter thingamabob(the thing the filter screws on to don't know the exact name of it) no change .The pressure was good earlier the only thing we did to it was took out the break in oil and filter and put it the racing oil (valvoline racing 20-50) Whats the deal.


NWModracer
Member
posted April 15, 2002 12:04 AM
Yeah the break in oil was thinner I am going to look at a couple things tommorrow then I will probally pull the pan and try to figure things out


ryan
Member
posted April 16, 2002 12:04 AM
Nevermind Figured it out


wam24u
Member
posted April 16, 2002 08:59 PM
Well,,,,,here's the deal. When we put on the second filter it wasn' completly tight so it leaked some oil we didn't think it was very much(very little oil on the ground) so we tightened it up some more and went on our way,soon after that is when our trouble began. Little did we realize how much oil actually came out because the drain pan was right underneath it. So to make a long story short(too late) I missed a night of racing because I WAS LOW ON OIL.
Flatlander e-mailed mrrequipt might get a single from him I have to take my other head in yet. I have been too busy busting my rear trying to get that dang car done. Thank god it's finally done (I think)lol


Flatlander
Member
posted April 17, 2002 07:28 AM
Well thats great good luck and have fun cause thats what makes all these agravating times worth going thru and be safe the Flatlander


Back to the Archives