Visit The Dirt Forum for More Information

Author Topic:   Engine timing / Valve timing
BB46
Member
posted June 25, 2001 07:53 PM
Check your harmonic balancer. If it's spun it will throw everything off. We've run into that problem before.


BB46
Member
posted June 25, 2001 08:56 PM
Hey butch we just ran into that same problem befor we blew the good motor at yakima. It was the balancer it was brand new and it was slipping from the outer ring,not sure if the fluid dampner is solid or 2 peice. Might want to check for a vacum leak also just tring to help, Glad to see ya out there but it would be better to see you back!! Email me if you need anything.18436572

[This message has been edited by dirtracer14 (edited June 25, 2001).]

BB46
Member
posted June 25, 2001 09:55 PM
We lost the 377 at state fair 2 weeks befor the nats and couldnt get parts in time, the motor from friday was the same motor we lost last year at the nats we tried it again and we had balance problems, and leroy lost the big gun this sat.I run about 150s with my flat tap cams ( cant afford rollers ).I hope you can get it figured out the car looks real nice,not much time to look around we were kinda busy hope to see it out there soon! Just give it a check i have over looked it many times is firing order? Is the water getting real hot lots of pressure on the hoses, Do you have a flow restrictor in it? If you want ill be on the live chat here for a little bit!

[This message has been edited by dirtracer14 (edited June 25, 2001).]

booting left
Member
posted June 27, 2001 11:13 AM
we have come across this problem also
check the harmonic balancer to see if the outer ring has moved.we always mark the front of the balancer to quickly check for problems,if the marks move away from each other change the balancer


Back to the Archives