Visit The Dirt Forum for More Information

Author Topic:   belts keep coming off
LUBEGUY07
Member
posted April 21, 2002 09:39 AM
i am having trouble throwing my p/s belt off the pump is aligen right and i use new belts with stock pullys should i go with aftermarket pullys. I dindt have this trouble before we switch gears and the cars turns a lot more rpms now . Any advice? thanks alot


LUBEGUY07
Member
posted April 21, 2002 09:44 AM
if forgot to say i run a two belt system one for alt and one for p/s both have seperate groves on the water pump pully and crank pully, also iam turn 7000 rpms too



dirtracer17
Member
posted April 21, 2002 11:58 AM
get some pullies and black spray paint


LUBEGUY07
Member
posted April 21, 2002 02:13 PM
i have been using gates belts,and 17 j what type of pulleys u sugest, have u raced yet this year


jammin
Administrator
posted April 21, 2002 02:27 PM
Top Gog Dayco belts are great...they wont stretch.

jammin

Scoot
Member
posted April 21, 2002 09:01 PM
I've heard a large fan can cause this at high RPM's. I personally haven't had this problem though.

------------------
Scoot
Smith Racing Team
870-365-5989


dirtracer17
Member
posted April 21, 2002 09:34 PM
just get the aluminum ones from midwest and paint them black we aren't suposed to run them but they don't carry a magnet with them so he will never know. and no i haven't been out yet i have done all the work on my car myself this year so it's taking a little longer than i had hoped should be out in a couple weeks white and blue malibu with purlpe and neon orange 17j


racer17j
Member
posted April 22, 2002 12:58 AM
was that the same guy driving last nite or did he just get a new suit?


te33
Member
posted April 22, 2002 07:25 PM
ok thanks for the advice we are going to try dayco top cogs belts friday night and if they dont work going to try some aftermarket pullys. and 17 j we had Terry Buenting from ftdodge drive it in heat race to help us fix the push it had and man did it work we didnt have enugh rear stagger we changed it and it worked still a litty doggy of the coners but man the thing likes to rev up.I talked to the tech man at britt and he said we could run aftermarket pullys ,see u on the track in a couple weeks



racer17j
Member
posted April 24, 2002 01:06 AM
so what did you put in it for a gear she was a screamer from up top anyway


LUBEGUY07
Member
posted April 24, 2002 08:42 AM
we put 410 in it and tried 225 75 15 and then tried 205 75 15 they worked better



Back to the Archives