Visit The Dirt Forum for More Information

Author Topic:   need help fast
Jesterondirt
Dirt Full Roller

Total posts: 56
posted April 29, 2005 10:29 PM  
I have just recently installed disk brakes on the rear of my camaro factory stock. i am still using the stock master cylinder, have bled all the air out, but the pedal goes all the way to the floor and does not stop the rotors, had no problem before with the drum brakes. anybody know anything?

Eljojo
Dirt Forum Champ
Total posts: 968
posted April 30, 2005 04:38 AM  
The wheel cylinders used to activate drum brakes require very little fluid to activate. The calipers need much more fluid. If you looked into your master cylinder you will notice there are two reservoirs, the front one is for the disc brakes and the rear is for the drums. I suspect that you will have to replace the master with one designed for two sets of discs.
This is just my opinion...perhaps one of the top mechanics will reply and support this theory, or give you a more plausable answer.

JYD97RACE
Dirt Roller

Total posts: 8
posted April 30, 2005 10:29 PM  
Eljojo is right.If you want to check just swap the lines at the master cylindler. The front wil stop working and the ack will go to working. good luck.
The Race Is On!!
RickyG

thrill hill
Dirt Full Roller

Total posts: 59
posted May 01, 2005 05:43 AM  
Our car has the front line going to the rear and rear line going to the front. Is this factory correct for discs all the way around. we don't have the best brakes?

Jesterondirt
Dirt Full Roller

Total posts: 56
posted May 02, 2005 10:21 PM  
that worked, for the weekend we blocked off the back resevoir and piped them all into the front Thanks for the help

    

Back to the Archives