Visit The Dirt Forum for More Information

Author Topic:   setup help
southern4020
Dirt Roller

Total posts: 7
posted March 02, 2005 07:30 PM  
Ok fellas I'm new to this so bear with me.We have a 68 chevelle chassis and over the winter we have set it up(with a lot of help from this site)we are running 3307lbs with a 900lf 1100rf 250lr 225rr we have 53.6% LEFT 49.2% CROSS and 52.4%REAR and 100lbs left rear bite the car has a torque link and it is at 12 degrees up in the rear the lower control arms are 12 degrees also we have 1/2" stagger in front and 2 1/2" stagger in the rear. we practiced for the first time and the car was great the track was wet and very tacky and the harder we drove the car the better it handled then this week the track went dry slick and the car pushed bad seemed like it would turn in and then push in the middle and be loose out.what would you fella's try. the track is 3/8 mile high banked and we run racing tires, thanks

The Flash32
Dirt Maniac

Total posts: 120
posted March 02, 2005 07:39 PM  
Sounds alot like my set-up, but we changed alot of things over the winter. Did you change stagger any for the dry-slick? Do you run the balance bar set-up on the brakes? How did you enter the turns on dry? I know we run very little stagger for dry & run alot of front brake. Hard on the brakes just before entering the turn. Seems like I am just too slow in the turns but when others are pushing & spinning their tires, we are gone!!!!

justin
Dirt Freak

Total posts: 263
posted March 02, 2005 08:04 PM  
You might wanna try bumping up your cross or lowering you RF spring rate a little bit. This should loosen you going in and thru the turn and tighten you coming off on exit.

Justin

    

Back to the Archives