Visit The Dirt Forum for More Information

Author Topic:   Power Steering
RACINREBAL6410
Dirt Full Roller

Total posts: 43
posted October 10, 2004 05:42 PM  
Anybody have any trouble loosing power steering during a race changed box, put differnt fluid in in it (the non foaming stuff) only thing i can figure it is is the pump any help would be appreciated

joetaylor
Dirt Forum Champ
Total posts: 640
posted October 10, 2004 06:54 PM  
do you have any signs of a leak that is where I would start if you are loosing the steering then It must be leaking

------------------
if every thing is under control your not fast enough

RACINREBAL6410
Dirt Full Roller

Total posts: 43
posted October 10, 2004 07:26 PM  
No it dosent leak at all its still full of fluid Its beeen doing it for a while and im sick of it i gotta figure out what the problem is

racer17j
Dirt Forum Champ
Total posts: 5390
posted October 10, 2004 08:46 PM  
Belt slipping under at high rpm maybe?


joetaylor
Dirt Forum Champ
Total posts: 640
posted October 12, 2004 08:08 PM  
ANOUTHER THOUGHT THE PRESSURE SPRING COULD BE GIVING OUT ONE OUTHER Q WHAT ARE YOU USING FOR PS FLUID i USE AW32 HYD OIL

------------------
if every thing is under control your not fast enough

RACINREBAL6410
Dirt Full Roller

Total posts: 43
posted October 13, 2004 01:59 PM  
Called sweet its where the pump is made the guy said that he thinks it the fluid breking down went to royal purple to try that thanks for all the advice

The Vanburen Rocket 22
Dirt Full Roller

Total posts: 30
posted October 13, 2004 02:37 PM  
we had that problem two years ago with a sweet power steering pump it was all new,we went and changed everything,another new pump new hoses new belts changed sizes of hole in fittings.still the same thing,we finally changed the tank that held the fluid,for the **** of it. It turned out to be the problem the whole time.Something about the way the fluid shot through it, it swirled or something,the new tank, the placement of fittings were different it fixed the problem,it did not swirl no more,they said something about it was making air the whole time it was swirling or something.anyway you might try it if nothing else works.

[This message has been edited by The Vanburen Rocket 22 (edited October 13, 2004).]

RACINREBAL6410
Dirt Full Roller

Total posts: 43
posted October 13, 2004 06:31 PM  
does the distance that the resavoir is from the oump matter or the height above the pump

The Vanburen Rocket 22
Dirt Full Roller

Total posts: 30
posted October 14, 2004 04:24 PM  
racingrebal6410,no the distance or height shouldnt matter,when i was having trouble i mounted the new canister in same place as old one.the way the two fittings were in the canister as far as location of fittings,cused the fluid to swirl alot under power which caused it to make air.the new canister had different location for fittings,and it didnt make the fluid swirl near as much.I dont remember the brand of canisters we had originally or switched to,because I just drove the car for another guy.I'f you have some buddies with same steering pump as you, you might check which cannister they are using.I't might not be your problem,but if you changed everything else like we did,it is a good possibility.Have you been running that cannister all year,if so did it work right before.if it did work right originally,it probably is not your problem.if a buddy has a spare pump try his see if it fixes it?

    

Back to the Archives