Visit The Dirt Forum for More Information

Author Topic:   Overheating - any ideas why?
allzway
Dirt Maniac

Total posts: 136
posted April 12, 2004 11:57 AM  
My car got very hot at the end of the feature this last weekend.

It just slowly crept up. Was at about 230 when I left the track and was pegged by the time I got to my pits.

Currently, I have a flex fan that is mid way of the shroud and I run the mid-size water restrictor.

Stock water pump with griffin radiator.

Any ideas here?

outlawstock17
Dirt Forum Champ
Total posts: 1363
posted April 12, 2004 12:28 PM  
check your radiator cap.....also, ditch the flex fan and get a stiff 4 blade...

allzway
Dirt Maniac

Total posts: 136
posted April 12, 2004 01:51 PM  
quote:
Originally posted by outlawstock17:
check your radiator cap.....also, ditch the flex fan and get a stiff 4 blade...

The fan is going today...several guys I talked to said the flex fan is probably the culprit.

It never has gotten hot at idle. It started getting hot after the heat race and then did get hot at the end of the feature.

I double check the cap also.

Thanks,

James

Flanndad
Dirt Freak

Total posts: 255
posted April 12, 2004 02:01 PM  
A will agree to get rid of that flex fan.

One more thing, if you grab the fan can you turn it by hand. Make sure it isn't slipping.

The reason I ask is, I had a power steering leak that was greasing up the belt and pulley, which would let the fan slip.

Mine would do the same thing, it would get about 215* to 220*, but slow down for the pits and it would climb real fast

STREET16
Dirt Maniac

Total posts: 158
posted April 12, 2004 06:41 PM  
What's your timing set at?

allzway
Dirt Maniac

Total posts: 136
posted April 12, 2004 06:56 PM  
I believe the timing is set at 36.

STREET16
Dirt Maniac

Total posts: 158
posted April 12, 2004 07:03 PM  
Then, it's probably not your timing. I have too agree with everyone else - lose the flex fan.

gearjammer_880
Dirt Roller

Total posts: 17
posted April 12, 2004 07:46 PM  
i dont know exactly what your set up is but i run a 3 core copper radiator in my street stock and mine never gets over 190-200 cause i have pieces on the top and sides in front of my radiator cause before the air would always go around the radiator not threw it it might not be the answer to the problem your having now but will help if you dont have this already done. and also i agree junk the flex go solid.

te33
Dirt Freak

Total posts: 237
posted April 12, 2004 10:27 PM  
was it muddy in the heat,warm-ups?did you back flush your rad.before the feature?it might look clean,but you will be amazed at what will come out when you hit it with the hose.just an idea,...

allzway
Dirt Maniac

Total posts: 136
posted April 13, 2004 07:10 AM  
Thanks for all the replies. I am really thinking it is the flex fan now, but will also check out the shroud and radiator cap.

PerigoRacing
Dirt Roller

Total posts: 11
posted April 13, 2004 12:35 PM  
I use a flex fan and have no probs,Maybe you should try water wetter or something like that JMO

maxwell
Dirt Full Roller

Total posts: 46
posted April 13, 2004 02:26 PM  
use 1 to 1 pulleys fans shroud,no restrictors and a 4 blade fan is the best just cut it to the lenght that is required.run a little antifreeze to lube the water pump.This is information from Stewart and warner tech man i was having the same problem for 2 year till i got it correct also soak the radiator in a swimming pool for to days that will really help you may have to do this ever weekend try it and let me know how it work

gould
Dirt Forum Champ
Total posts: 730
posted April 13, 2004 07:54 PM  
i use a flex fan, alum radiator, thermostat with no guts and a homemade shroud. stock pullys. mine runs 180 190 with 38degrees timing. figure that one out!

------------------
www.geocities.com/gouldracing11

gould
Dirt Forum Champ
Total posts: 730
posted April 13, 2004 08:00 PM  
was there a air pocket in the system? with stock pulleys at a high rpm your water pump cavitates and doesnt move water. get some aluminum pulleys with 25%underdriven on the crank. it will turn the pump slower.i got the pulleys cause i cant keep belts on, lol.

------------------
www.geocities.com/gouldracing11

[This message has been edited by gould (edited April 13, 2004).]

dirtdodge
Dirt Roller

Total posts: 18
posted April 13, 2004 08:25 PM  
most everyone here thinks flex fans are no good.i run one and my car never over heats and cools down on cautions 200 tops after a feature.do you run stock pulleys.can you run after market pulleys. ditch the restrictor and see how much air your pulling through the rad if it isnt enough your going to heat

allzway
Dirt Maniac

Total posts: 136
posted April 14, 2004 08:04 AM  
I do have the pulley combination.

I put on a 4 blade steel fan and will give it a try.

Next I think I might try an aftermarket pump.

redneck racing
Dirt Forum Champ
Total posts: 860
posted April 17, 2004 05:12 PM  
Try adding some water wetter or hyper-lube to bring it down. Eddie

racer17j
Dirt Forum Champ
Total posts: 5390
posted April 17, 2004 05:24 PM  
gould the reason yours is running so cool right now is because it's been below 40* out both nites youv'e raced so far bellieve me that flex fan will hurt you come july

    

Back to the Archives