Visit The Dirt Forum for More Information

Author Topic:   carb help
blade
Dirt Full Roller

Total posts: 34
posted March 16, 2005 06:17 PM  
the carb is 2bbl on a 302 ford the car won't start and just idle to start it you have to hold the gas pedal at half throttle for about 30 seconds then it runs great, if you don't,it runs for a few seconds and then stalls and is very hard to stop after that. any ideas would be great help! thanks

petordragon
Dirt Maniac

Total posts: 167
posted March 16, 2005 06:24 PM  
the bowel might be draining takes little bit to fill back up. Could be a leaking gasquet. Is it running rich after it gets running?

blade
Dirt Full Roller

Total posts: 34
posted March 16, 2005 06:31 PM  
when it first starts is a little rich but not to bad. once it is runing not rich at all.

blade
Dirt Full Roller

Total posts: 34
posted March 16, 2005 06:33 PM  
forgot it is leaking a little bit when you walk into shop small smell of gas

merlinmech2
Dirt Maniac

Total posts: 131
posted March 17, 2005 06:59 AM  
sounds like your float is set too high.

petordragon
Dirt Maniac

Total posts: 167
posted March 17, 2005 10:53 AM  
open element filters will let gas evaporate out of the bowel. can usually be fixed with an electric fuel pump. Most rules don't allow electric fule pump. mine will do same thing if it sets for a week or so only gas that is left in carb will be in the accelarater pump just enough to get it to start till manual pump gets fuel to the carb.

Alan Rat
Dirt Roller

Total posts: 15
posted March 19, 2005 07:01 AM  
A leaking power valve will cause this same symptom. It will leak the fuel out of the bowl
This makes for a over rich condition on start up, and engine will have to spin over a lot to refill the float bowl. Good luck

Back to the Archives