Visit The Dirt Forum for More Information

Author Topic:   Rear Hubs Cracked
wrench1
Dirt Roller

Total posts: 6
posted January 11, 2005 12:37 PM  
Has anyone ever had the Hub crack where the rotor ring lug joins the hub? The manufactuer says they don't have a problem with this happening.

awkwardjeff
Dirt Forum Champ
Total posts: 562
posted January 11, 2005 01:46 PM  
I know people are going to get on here and say the calipar bracket is not square to the rotor. The other thing people will say is the rotor was run loose.... I don't buy anything other than a manufactor problem. The rotors are cast the hubs are machined and are MUCH stronger than the rotor.... any alignment problem or running loose problem would show up in the rotor.

I assume there was NO damage to the rotor?? CORRECT

quote:
Originally posted by wrench1:
Has anyone ever had the Hub crack where the rotor ring lug joins the hub? The manufactuer says they don't have a problem with this happening.


wrench1
Dirt Roller

Total posts: 6
posted January 11, 2005 02:42 PM  
Rotors look perfect and everything looks straight. Car never ever wrecked, all new 13 weekly show nights ago.

FlyNLoIMCA17
Dirt Forum Champ
Total posts: 753
posted January 11, 2005 03:51 PM  
Maybe you just got a bad hub from the manufacturer????? I've not had any experience with this......

Alltel
Dirt Maniac

Total posts: 180
posted January 11, 2005 06:00 PM  
I've had them break completely off. I lost the brakes mid race, and imagine my surprise when I got out and saw that all the tabs had broken off and the rotor was just floating around the axle housing. It was a coleman hub.

Back to the Archives