Visit The Dirt Forum for More Information

Author Topic:   Tranny Mount?????
vosevichs
Dirt Forum Racer

Total posts: 78
posted May 03, 2004 11:48 AM  
Bought a lightened 3 speed Saginaw and the first one was cracked at a ear. Returned it and and got a new one. Didn't notice any leaks when first installed. But now it's cracked at 2 ears. Was it cracked when we got it???? Don't know. It's going back, hopefully they will exchange it. Tracks have been really rough around here this first couple of weeks. So we are considering a mount. Any suggestions?? Last year we ran a stock rubber mount under a powerglide on the old car. This Mod allways had a Bert in it until this year.
Thx.

------------------
Scott Vosevich
RDBoyz Racing

racerwilson
Dirt Freak

Total posts: 357
posted May 03, 2004 01:53 PM  
can you go back to a Bert. I never had any problems with my Bert. Very reliable.

vosevichs
Dirt Forum Racer

Total posts: 78
posted May 03, 2004 02:09 PM  
Would if we could. We run in a B- mod class 2 barrel carb w/gas and no berts or brinns.

NJantz
Dirt Forum Champ
Total posts: 755
posted May 03, 2004 02:44 PM  
here's what I use: http://www.thedirtforum.com/ubb/uploads/NJantz/MVC-011F.JPG

nate 11
Dirt Freak

Total posts: 316
posted May 03, 2004 05:59 PM  
thats a good idea NJantz.....

imca35
Dirt Roller

Total posts: 17
posted May 03, 2004 07:28 PM  
Scott,
Check your clearance on your yoke to make sure you are not bottoming the yoke into the tranny. I kept breaking the upper drivers ear off and I think that was the problem. Great Tranny mount!!!
Curt Clegg

MOD75D
Dirt Freak

Total posts: 236
posted May 03, 2004 08:16 PM  
NJantZ did you make that or did you buy it? Thats an awsome idea.

vosevichs
Dirt Forum Racer

Total posts: 78
posted May 04, 2004 06:25 AM  
Check the Clearence when we first install the 3 speed and new driveshaft. Thats all good.

------------------
Scott Vosevich
RDBoyz Racing

NJantz
Dirt Forum Champ
Total posts: 755
posted May 04, 2004 06:34 AM  
That is a home built special! I used to run the same mount on my powerglides but I used spacer tubes to tie the supports to the back of the heads along with some 4" bolts.

Ego Racing
Dirt Forum Champ
Total posts: 724
posted May 04, 2004 10:37 AM  
NJantz
That is exactly the same type setup we ran on our PG's

Back to the Archives