Visit The Dirt Forum for More Information

Author Topic:   Powerglide shifting problems
dirtracer50
Dirt Forum Racer

Total posts: 98
posted April 24, 2004 12:26 AM  
Over the winter I built a new powerglide for my car and I've got problems. Low gear and reverse both work fine but It won't shift into high gear. I've pulled the valve body apart three times now checking and cleaning the valves including the one two shift valve. I tried putting vacum to the modulator and that didn't change anything. I've been through all my books and can't find the problem. This is the third one I've rebuilt and I thought I did everything the same as the first two that work great. Any suggestions would be greatly appreciated.

FASTLAP
Dirt Maniac

Total posts: 171
posted April 24, 2004 05:00 AM  
Ran into a similar situation a few years ago, turns out the valve body had a small crack in it. Just a thought. Can't remember how I found it, though.

autodoc999
Dirt Full Roller

Total posts: 53
posted April 26, 2004 10:32 PM  
You may have sealing ring problem at the pump. When you assemble the trans and before you put the valve body in, air check high gear clutches. That will help eliminate a mechanical problem. If you still need help, You can call me at my shop 501-767-4414...Paul

Alltel
Dirt Maniac

Total posts: 180
posted April 27, 2004 06:11 PM  
If low and reverse are working, then it's a high gear drum problem. Did you check the endplay in it at the input shaft? If there is too much, the drum will walk off the seals and it won't go into high, or if the inside of the drum is worn, it will do the same thing. Either that or no fluid is getting up there to the drum. If it does this, more than likely the clutches will be fried in the drum.

dirtracer50
Dirt Forum Racer

Total posts: 98
posted April 28, 2004 05:17 PM  
Thanks for the reply's guys. I checked the high gear clutches with air and they are working with air. The problem is it doesn't even try to shift. I did check the endplay and I put new sealing rings on the pump to drum. I was told you can get rid of the governor does anything need to be plugged to do this? Thanks for the help.

autodoc999
Dirt Full Roller

Total posts: 53
posted May 11, 2004 10:11 PM  
Dirtracer50 check your PM

Back to the Archives