Visit The Dirt Forum for More Information

Author Topic:   help
str8racing
Dirt Full Roller

Total posts: 65
posted May 15, 2005 08:46 AM  
fire 2.3 in garage before yesterday before races. smoked some let get up to temp, shut down. then would'nt start again found timing belt loose and crank would turn by hand. major problems? should i take it out back and shoot it?

Dunnracing98
Dirt Full Roller

Total posts: 63
posted May 15, 2005 10:37 AM  
no just take it part and find out whats wrong then ifit happens again you know and then you also know what to make stronger in you engine next time

str8racing
Dirt Full Roller

Total posts: 65
posted May 18, 2005 06:30 AM  
what kind of rings do you run, and how do you get them to seat and not blow by. any tricks? i have kb pistons and manley rods.

kurzhaar11
Dirt Roller

Total posts: 17
posted May 18, 2005 08:05 AM  
Sounds to me like you didn't tighten your idler pulley before you cranked it up. If it's a new belt and you only ran it in the garage, that'd be my guess. You shouldn't get a stretching of the belt thats noticable in that short of time.

Far as smoke goes, no one can probably answer that question. It could be alot of things. Is it a newly built motor or has it been run before? If you can turn the crank by hand, Im guessing it isn't newly built. Check your compression on all 4 cylinders. Id start there.

str8racing
Dirt Full Roller

Total posts: 65
posted May 23, 2005 06:48 AM  
found that i used the wrong rings, needs 1/16 1/16 3/16 had to order them. thanks for all the help.

Back to the Archives