Visit The Dirt Forum for More Information

Author Topic:   temp ?
charlie_two
Dirt Full Roller

Total posts: 53
posted May 20, 2002 12:53 PM  
hey guys i just got a late model, took motor, and radiator out of my mod, didnt move timing or anything, running alky, motor got up to 220 in hot laps the other night, broke tranny on first lap of heat so didnt get to try it any more, i got that fixed and what i was wondering, do i need to run a fan shroud, never ran one in the mod but it looks like with the late model it cant get much air to the radiator, also do i need to cut a some wholes in the nose, what else could i do, also how close to the radiator should the fan be? any ideas would help, thanks
charlie



NRG77
Dirt Full Roller

Total posts: 31
posted May 21, 2002 01:57 AM  
I don't know if this helps but we run an electric fan, we figure why give up horsepower running the fan when you don't need it. A shroud should give you better air flow, but be sure to check for other solutions, check your jetting and timing, you may be turning more rpm in the late model which may be a part of the cause.

limlate7r
Dirt Roller

Total posts: 20
posted May 26, 2002 06:50 PM  
This might sound like a stupid question, but did you burp the cooling system?

charlie_two
Dirt Full Roller

Total posts: 53
posted May 27, 2002 03:03 PM  
we put a shroud on it and it pretty much fixed it i think till the water pump broke and the fan went through the radiator. thats the way my luck is. thanks for the help though guys

Back to the Archives