Visit The Dirt Forum for More Information

Author Topic:   upper radiator hose swelling
holeshot
Dirt Maniac

Total posts: 119
posted October 05, 2005 08:36 AM  
after the main event my upper hose looks like it just got done with a hustler mag. tried a new hose and tried block sealer but still swells. it holds the swelling all week or when i take off the radiator cap and it only does it after the main not the heat race. it also does not put water into the overflow. any idea's?

mike9
Dirt Full Roller

Total posts: 72
posted October 05, 2005 09:38 AM  
sounds like a cheap hose and a high pressure cap i would get a reinforced hose or do like i do use alum or steel tubing and short sections of hose on ends i run a 28/32 pound cap and no problems most hoses for the street are used on 10-12 lb systems

ryan
Dirt Forum Champ
Total posts: 776
posted October 05, 2005 10:23 PM  
Do you have a stewart water pump by chance. I had one do that after upgrading to a quality pump and having a cheap-o hose. Get a quailty napa hose and your problem will disappear.

holeshot
Dirt Maniac

Total posts: 119
posted October 06, 2005 08:05 AM  
I will try a better hose. The one thing I forgot to say is that I put my other motor in because of the hose and the new one does not do that with same pump and hose.

ryan
Dirt Forum Champ
Total posts: 776
posted October 06, 2005 08:14 PM  
Does one have a different restrictor in it?

holeshot
Dirt Maniac

Total posts: 119
posted October 07, 2005 08:24 AM  
yes they do have different restricters but I think they run about the same water temp. the one that swells does have the smaller restricter so I will look in to that. Thanks

Back to the Archives