Visit The Dirt Forum for More Information

Author Topic:   Ever had this happen?
Hoosierdaddyracin
Dirt Roller

Total posts: 17
posted September 01, 2005 06:41 PM  
This last week we won our heat and our feature but after the feature we kept hearing a rattling noise. We loaded up putting the diagnosis off until Monday. When we started looking around the engine and pulling on everything. My dad expected the water pumps bearing to be worn out but come to find out it was the Harmonic balancer that had came apart. I thought that was weird< has that ever happened to any of you guys?

------------------
Speed kills burn rice

droper23
Dirt Freak

Total posts: 233
posted September 01, 2005 06:58 PM  
I used to run a stock balancer. One time we had the outer ring (the part on the outside of the rubber o-ring thing) break in two pieces.

racer17j
Dirt Forum Champ
Total posts: 5390
posted September 01, 2005 07:57 PM  
I have the pieces of one that came apart while setting the timing in the shop. Should have seen the look on the faces of the two guys that were there that night. lol

leapinlizard
Dirt Freak

Total posts: 402
posted September 02, 2005 07:50 AM  
I've seen it happpne more in drag racing. When the rubber get's shock loaded at launch. Drag guy's seem to use stock press on style more often. Older chevy 327's didn't even have a bolt to hold it on.

Hoosierdaddyracin
Dirt Roller

Total posts: 17
posted September 02, 2005 02:00 PM  
Yeah LoL I only race in the bomber stock division. It didn't break into peices it came off of the o-ring.

------------------
Speed kills burn rice

Hoosierdaddyracin
Dirt Roller

Total posts: 17
posted September 02, 2005 02:01 PM  
Yeah LoL I only race in the bomber stock division. It didn't break into peices it came off of the o-ring.

------------------
Speed kills burn rice

Mr. Badboy
Dirt Full Roller

Total posts: 29
posted September 03, 2005 10:29 PM  
The stock harmonic balancer has a rubber that holds the hub and the inertia ring together. When the rubber gets old, it shrinks, and before it launches the inertia ring it will sound like the motor is about to throw a rod. It's a matter of old age for the rubber.

Raz_900
Dirt Forum Champ
Total posts: 635
posted September 05, 2005 06:27 PM  
I tried a Professional Products or sumthing like that last year. It was the small dia. LW high RPM piece. After 4 weeks and never over 6200 the rubber bond came loose and the outer ring was wobbling. Went pack to Pioneer Performance piece (the one that's around $100, not the $50 stock replacement) and won't ever try a 'cheap' one again.

[This message has been edited by Raz_900 (edited September 05, 2005).]

samiller
Dirt Roller

Total posts: 14
posted September 11, 2005 06:57 AM  
when we ran stock balancers. had to keep checking the rubber for cracks and twisting.not only will it come apart,but timing could get messed up.

Racer111
Dirt Freak

Total posts: 259
posted September 11, 2005 05:47 PM  
Run a ATI balancer ther well worth it.

D9Dave
Dirt Full Roller

Total posts: 43
posted September 24, 2005 10:37 AM  
mine twisted on the rubber got the motor off time real bad. fluid dampner works great

Back to the Archives