Visit The Dirt Forum for More Information

Author Topic:   Oil Pressure Fluctuation
mcwheely88
Dirt Newbie

Total posts: 3
posted August 22, 2005 08:36 AM  
355 Chevy 9.1 comp, stock pan. Just got hit buy a guy and had to slam on the brakes (power). When I stopped low press. light came on then went out (set at 20 psi). Started racing again and noticed a couple laps later that the oil pres was going from 60 to 40 and back up to 60 down the straight when adding power. It was normal in the turns. Bypass not blocked. Bad thing used Fram filter. Started it up the next morning to take off the trailer and press fine. Water temp 190. Could it just be the filter? Will change to wix next race. 200 lap endros. Thanks for the help.


mcwheely
Dirt Roller

Total posts: 8
posted August 22, 2005 02:21 PM  
btt

leapinlizard
Dirt Freak

Total posts: 402
posted August 23, 2005 08:47 AM  
Low oil level and no baffles in the pan?

mcwheely
Dirt Roller

Total posts: 8
posted August 23, 2005 04:15 PM  
Only burned 1/4 quart of oil and stock baffles in pan. First time this has happened in 2 seasons.

hoosierdaddy48
Dirt Maniac

Total posts: 107
posted August 23, 2005 04:18 PM  
same thing happend to me, pick up tube fell off.

mcwheely88
Dirt Newbie

Total posts: 3
posted August 23, 2005 05:41 PM  
Checked that to. Put a screwdriver in the oil plug and felt around and it was attached.

Hoosierdaddyracin
Dirt Roller

Total posts: 17
posted September 02, 2005 02:18 PM  
My car does that only when it gets hot. when i come in the pits the oil presure is below 20psi, but we use restrictors

James Ott
Dirt Maniac

Total posts: 131
posted September 02, 2005 06:14 PM  
Did you notice oil on the motor down the right side after the cras?

racer17j
Dirt Forum Champ
Total posts: 5390
posted September 02, 2005 08:15 PM  
i would get a wix filter and check to see if the gauge line didn't get pinched . how much oil are you running ?

Back to the Archives