Visit The Dirt Forum for More Information

Author Topic:   s 10
19J
Dirt Freak

Total posts: 370
posted June 25, 2005 04:50 PM  
I have a 90 s10 with a 2.5 fuel injection. It runs just fine for about 4 mins or so. Give or take. Then it gets this noise and starts missing if you try to climb a hill it falls flat on its face. Its getting worse. It used to just have a noise but now its doing that. Then the oil pressure guage started bouncing it would never stay down for more than 1 second tho. It says it has 80 lbs oil pressure all the time. But a guy thinks the guage is junk could very well be. But it almost seemed like the miss was when it dropped and the check gage light came on. I thought maybe it was oil filter collapsing then losing pressure even tho there should be a by pass maybe too much pressure for bypass or something i dont know or its sticking but they assure me that its not my filter. That the filter i have on it will hold any oil pressure that s10 has. Its a microguard. They think it could be a fuel pump going bad or module or coil. What is your thoughts? I think i might have them scan it but havent decided yet. All help appreciated thanks.

WPP
Dirt Freak

Total posts: 451
posted June 26, 2005 06:21 AM  
I would check your fuel pump i know a guys that done the same thing when he first started the thing it ran all right idleing but when started driveing it would fall on it face he changed lots of things and finally found out it was the fuel pump

Back to the Archives