Visit The Dirt Forum for More Information

Author Topic:   Pre Ignition
Rookieracer76
Dirt Freak

Total posts: 289
posted June 20, 2005 03:58 PM  
raced my car yesertday and overheated (24o*)so i shut the car off let it cool and went back to restart it about 15 minutes later. while it was running tho the temp went up..way up past 280*(gauge only goes up to 280 and it went past). i tried to shut the car off but it wouldn't shut off. someone told me it was due to pre ignition. what causes this? also what should i check after having the car over heat? thanks

racer17j
Dirt Forum Champ
Total posts: 5390
posted June 20, 2005 07:08 PM  
Running to much compression and not enough octane causes it. Same thing 17j said, just in the form of a question.

spray004
Dirt Full Roller

Total posts: 29
posted June 21, 2005 06:37 AM  
Too much compression & not enough octane. Since the engine is so hot its causing the fuel to combust even after the ignition is off. Same way a diesel engine works in a way.

Rookieracer76
Dirt Freak

Total posts: 289
posted June 21, 2005 07:06 PM  
compression is probally around 11.5-1 at least that was what i was told. was running 89/93 octane. do you think i should run cam2 ? what should i check to make sure the engine is still ok? thanks

racer17j
Dirt Forum Champ
Total posts: 5390
posted June 21, 2005 07:25 PM  
I agree with 17j, 93 octane just wont cut it with 11.5 CR. You should run at least 100 octane. Pull the heads and check everything out. 50 bucks for the price of another good set of head gaskets just to be sure is alot better than the price of a whole motor.

eaton89
Dirt Freak

Total posts: 268
posted June 21, 2005 08:38 PM  
Need to fix the temp issue. Getting that hot and too much timing along with a high ideal speed can cause the motor to do what you are describing. Just another opinion.

Back to the Archives