Visit The Dirt Forum for More Information

Author Topic:   Stuck Thermostat?
dluna
Dirt Freak

Total posts: 334
posted June 06, 2005 11:44 AM  
I was sitting in line for the heat race on Saturday and I noticed the temperature was over 190. I have a 180 thermostat and it has always sat right on 180 Ė 185 until I run the engine hard. It never gets over 210 even after the feature and the slow drive back to the pit. I was watching it closely and every 3 seconds or so, the gauge would make a leap up 5 degrees and stopÖthen 3 more seconds, then up 5 degrees. Finally when it got to 220, I shut it off (probably not the smart thing to do, but it just kept on rising). It got up to 230 after I shut it off. I waited until cars started coming off the track from the previous race and fired it up. It was at 220 or so, but I started moving right away. As soon as I started moving, it got down to 180 again. After the heat it was right around 205. I got involved in a wreck in turn 1 of lap 1 in the feature, so I didnít get to run it very hard, so the problem didnít show up.

Any ideas what this could have been? Could the thermostat just have been stuck? I hadnít ran the motor for 4 weeks prior to Saturday. Is a general auto part store thermostat good enough for a racing application? On alky by the way.

One more note, I had a valve seat leak at the beginning of the year and put Moroso Ceramic Seal in. No signs of water in the oil or on top of the head since then, but perhaps I didnít get it all cleaned out of the system and it was clogging the thermostat? Probably not much of an issue, but if this motor goes south, Iím done for the year.

Thanks.

dirtbuster
Dirt Forum Champ
Total posts: 2007
posted June 06, 2005 12:07 PM  
Id start with changing the t stat. Make sure you also have a couple 3/16 holes drilled in the flange of it to purge any air and let a little coolant bypass until it opens. Otherwise we ran a plain old t stat on alky and never had problems.

Also might check to make sure your belts are tight and arent slipping.

racer17j
Dirt Forum Champ
Total posts: 5390
posted June 08, 2005 10:33 PM  
So, how do you get it up to temp without a stat at the track? Do you just put something in front of the radiator to get it warm for hot laps? Mine gets back down to 140 Ė 160 before the Heat and the Feature, so itís a pain to get it up to temp without a stat. I donít like going out on the track until it hits 180*.

I tried reving the engine but it did not seem to help. I may have gave it too much throttle.

Thanks.

racer17j
Dirt Forum Champ
Total posts: 5390
posted June 11, 2005 11:11 PM  
i just let her run for about 5-10 minutes before the race and it brings her up to 180 runs 210 in the race

Back to the Archives