Visit The Dirt Forum for More Information

Author Topic:   Rochester
19J
Dirt Freak

Total posts: 370
posted May 09, 2005 10:33 AM  
I have a carb that when you shut it off it drains almost all the float bowl. Then you hold it to the floor crank like **** for 2 mins and it will start then stumble and clear up. Why is this thing doing that? Someone once said its getting internal vacuum. My question is is this true and if so what is causing it. Another person thought that its just a junk carb. I have no clue. To get it to idle at the rpm i want the butterflys are open some. Could this be the problem it dont have the lil holes in the middle of the butterflys should they be there or no? Weve been going nuts over this thing. It runs awesome on the track. Just getting it started. Thanks.

merlinmech2
Dirt Maniac

Total posts: 131
posted May 09, 2005 03:00 PM  
About has to be your gasket between the base and bowl. Also look for cracks around the bolt holes there.

19J
Dirt Freak

Total posts: 370
posted May 09, 2005 10:00 PM  
Im gonna pull it apart tomm but i dont think that is it. Cracks maybe but not the gasket. It is freshly rebuilt. We had a bunch of trouble with the needle valve now it is good until the float bowl drains and float drops. THANKS. Anymore thoughts? I work everyday this week including friday so i dont have time to go and build a new one even tho we might end up doing that anyway. But please anymore thoughts? KP whats your opinion? Fuel pump is rated at like 3-6.

19J
Dirt Freak

Total posts: 370
posted May 11, 2005 10:14 AM  
I pulled it all apart and the gasket matches perfectly and isnt slipped. I put it all back together. I guess if it still does it i will live with it until i get a new one.

KPLugnut
Dirt Forum Champ
Total posts: 1019
posted May 11, 2005 10:39 AM  
Whomever built the carb for you (did the machining) has probably drilled something they shouldn't have. There are no outlets that would allow fuel to drain the bowl dry on a 2G unless someone has improperly drilled thru into a fuel circuit or opened a hole from the main wells to the venturi...

KP

19J
Dirt Freak

Total posts: 370
posted May 11, 2005 12:34 PM  


 
Heres some pics. The other post is the better picture. It points to where im talking about cuz im not carb literate.its coming from the passenger side jet running down into that small lil hole on the underneath side. The other side doesnt go all the way through like the pass side does. Should this hole be there or what is the deal???? Is there anyway to fix this?Thanks.

[This message has been edited by 19J (edited May 11, 2005).]

19J
Dirt Freak

Total posts: 370
posted May 11, 2005 12:58 PM  

 
Ok i think this is gonna work this time lol.

juni
Dirt Maniac

Total posts: 184
posted May 11, 2005 07:07 PM  
There are two small idle air bleed holes in the booster cluster i have seen people block these off and when you shut the engine off it would siphon the bowl dry and flood the motor check and make sure the gasket under the booster set has the holes in it or if some one has block the holes on top
.

19J
Dirt Freak

Total posts: 370
posted May 11, 2005 10:34 PM  
Thanks but i found the problem like i showed in the previous post and picture i just need to know what to do about it. KP i really need your thoughts on this.

19J
Dirt Freak

Total posts: 370
posted May 12, 2005 08:41 AM  
anyone?

Back to the Archives