Visit The Dirt Forum for More Information

Author Topic:   running rough please help
mrteeshot
Dirt Maniac

Total posts: 127
posted April 17, 2005 08:25 PM  
we have timed it from 4 to 32 and it still bogs down
Olds engine 350 rocket
started from TDC set w dial gun from 4 to 32 runs at idle and while timing -even timed it at several diff rpms but when we give it da juice she pops and shakes bad -please help opening nite this Fri,
this is my car that I drove last year and when I put it away for the winter it was running fine passed it on to a buddy and we just cant get it to run

------------------
racing is way too cool gave up golf for it

http://chasinracin.com/cgi-bin/showpage.pl?ID=on_my_6

TEAMPCR
Dirt Freak

Total posts: 238
posted April 18, 2005 06:15 AM  
Sounds like Ignition problems. Check cap and rotor and mag pick up for corrossion. Could be one or more bad wires, or plugs.
Could even be some crud in the carb. Good Luck. Dave

avila
Dirt Freak

Total posts: 217
posted April 18, 2005 09:35 AM  
Have you done a compression or leak down type tests on all cylinders? Could be a bad
valve.

mdsteacher
Dirt Maniac

Total posts: 145
posted April 18, 2005 11:34 AM  
We had similar problem but didn't pop that much. We adjusted fuel pressure to about 7 pounds, checked compression in all cylinders, changed spark plugs (one wasn't firing that well), and replaced the plug wires (not cheap ones either). Still had the problem after the changes. Checked timing at 35 degrees. Decided to borrow someone else's timing light and presto, our timing was off 4 degrees retarded. We had a bad timing light. Car ran fast with lots of power once timing was fixed.

Back to the Archives