Visit The Dirt Forum for More Information

Author Topic:   need help immediatley on head issue!!
pbrcowboy2
Dirt Freak

Total posts: 380
posted April 12, 2005 08:32 PM  
my friend fired his new motor up and it ran for 30 mintues just fine then it lost compression on number 6 cylinder and it ended up breakin the intake pushrod in two and pulled stud out on 4 different cylinders!! these r 487 heads with a .600 lift spring stock valves, 0.30 over piston with 4 valve reliefs

[This message has been edited by pbrcowboy2 (edited April 12, 2005).]

Xtreme12x
Dirt Forum Champ
Total posts: 874
posted April 12, 2005 08:46 PM  
sounds like someone didn't put the heads together right... get the heads gone back through, the studs were probably mis-aligned when put together.

77k
Dirt Maniac

Total posts: 174
posted April 12, 2005 10:44 PM  
sounds like valves are hitting pistons.

Xtreme12x
Dirt Forum Champ
Total posts: 874
posted April 12, 2005 11:14 PM  
good point 77k
what class is the motor for buddy?

ctfarm
Dirt Freak

Total posts: 206
posted April 13, 2005 05:53 AM  
It could also be coil bind.Check the valve springs for correct installed height.


rico 08
Dirt Forum Champ
Total posts: 1139
posted April 13, 2005 06:09 AM  
The retainers are hitting the guides.

pbrcowboy2
Dirt Freak

Total posts: 380
posted April 13, 2005 08:17 AM  
The guy by the name of kevin is running a b-mod for blackbird bend speedway 9.1 motor.

He is running a PRC 106 cam from J.R. MOTORSPORTS(PG 42)

in lift is .544 and ex lift is .553

he is going to run the 5/16ths mile track with this cam a 500cfm 4412 with stock valves in a set of 487 heads with .600 valve springs from speedway. He also had to use +100 hardened pushrods cause stock length was way to small!!

now im running a 14103 cam from speedway and it is workin really really nice for my setup bad fast car!! and i have stock 882 heads with stock valves, and pushrods, with a .600 lift spring from speedway

[This message has been edited by pbrcowboy2 (edited April 13, 2005).]

Xtreme12x
Dirt Forum Champ
Total posts: 874
posted April 13, 2005 08:33 AM  
reguardless of what it is, they heads were assembled wrong, and you'll definately want some stainless valves in there..
What ratio rocker arms is he running

pbrcowboy2
Dirt Freak

Total posts: 380
posted April 13, 2005 08:49 AM  
stock ratio long slot

pbrcowboy2
Dirt Freak

Total posts: 380
posted April 13, 2005 08:55 AM  
just found out he just put these sprngs on and went with em he did not check his installed spring height!!

autoshop
Dirt Freak

Total posts: 298
posted April 13, 2005 09:14 AM  
I would double check the retainers and make sure they don't hit most do .That's why you machine the guide tops so the stud does not act like a level and pull out.

Back to the Archives