Visit The Dirt Forum for More Information

Author Topic:   problems problems lol
track_trash_66
Dirt Full Roller

Total posts: 50
posted April 02, 2005 06:04 PM  
ok here we go ,got motor all ready to run last weekend got it fired up and it kept flooding seems the needle for the float went bad and wasnt sealing up right replaced it now it runs fine . only thing is now i got it up to tempature and oil pressure droped to 20 lbs . thought might be the assembely lube so decided to change oil oil was verry thin and smelled alittle like gas and was dark color too. went got some new oil and lucas oil stableizer. put it in got to late to start so i dont know whats goin to happen. any idieas????

track_trash_66
Dirt Full Roller

Total posts: 50
posted April 02, 2005 06:54 PM  
anyone??

15a
Dirt Freak

Total posts: 354
posted April 02, 2005 07:04 PM  
Is it possible that when the carburetor was "flooding" that most of the fuel went past the piston rings and diluted the oil. That is probably why the oil smelled like gasoline and was black. When you changed the oil, did it appear that you drained more than you put in the engine when you first fired it up? If it is a newly built engine, I would do a compression test to see if the rings have sealed. Oil with fuel in it may not lubricate the cylinder walls and the rings may not seal. Just my idea of what to check for.

stockcar5
Dirt Forum Champ
Total posts: 578
posted April 02, 2005 09:20 PM  
check your oil filter. put a new one on when you change the oil. get a good racing filter like wix or a napa race filter (same as wix)

------------------
www.geocities.com/dirtstockcar5

leapinlizard
Dirt Freak

Total posts: 402
posted April 02, 2005 09:26 PM  
Oil pressure was probably low due to the thinning properties of gasoline. Especially those with paint thinner.

track_trash_66
Dirt Full Roller

Total posts: 50
posted April 03, 2005 05:14 AM  
thanks ill let you guys know what happens today

Back to the Archives