Visit The Dirt Forum for More Information

Author Topic:   "H" bearings
istock59
Dirt Forum Champ
Total posts: 501
posted February 24, 2005 07:04 AM  
Got a set of brand new Clevite "H" bearings given to me. I've always used the "P" style in the past. Took these out of the box last night to see what the difference was. On the "H" ones, there's all sorts of discoloration. Almost like it's heat related. Is this from when they cut the edge chamfer deeper? And if so, is it normal?

Thanks

outlawstock17
Dirt Forum Champ
Total posts: 1363
posted February 24, 2005 07:28 AM  
it's normal. they don't put the pretty finish on them...

gerald berry jr
Dirt Full Roller

Total posts: 32
posted February 24, 2005 08:34 AM  
those are very good bearings all we run

Xtreme12x
Dirt Forum Champ
Total posts: 874
posted February 24, 2005 08:48 AM  
Tracy,
Little Trick I learned from one of your competitors (Not going to say who just say its another Terminator from Marshalltown )
Take and use some parts washing fluid on a rag and polish all the bearings by hand to get the coating off. Car show is just around the corner, that car ready?

istock59
Dirt Forum Champ
Total posts: 501
posted February 24, 2005 09:32 AM  
Thanks all.

Car show? Have you ever seen my car at a car show? Don't think so...

Xtreme12x
Dirt Forum Champ
Total posts: 874
posted February 24, 2005 11:43 AM  
Well now's the time to take it...
LOL
What did you get for a crank?

istock59
Dirt Forum Champ
Total posts: 501
posted February 24, 2005 03:47 PM  
And have everybody paw all over it? Nah, I'll just keep it home.... Besides, not even painted yet.

Crank? I only run OEM. 265ci, ya know?

Back to the Archives