Visit The Dirt Forum for More Information

Author Topic:   Broken oil pump?
race8k
Dirt Forum Racer

Total posts: 98
posted June 17, 2002 10:33 AM
Have had the oil pump break off of a 355 chevy two weeks in a row.Anyone know why this happens?How about it Bill.

marty
Dirt Maniac

Total posts: 111
posted June 17, 2002 12:50 PM
Where has it broken?

BayouGent
Dirt Forum Racer

Total posts: 87
posted June 17, 2002 12:57 PM
How much torque are you tightening it to? I've seen em lose the stock pickups, but never break off (unless smashed). I'm curious to hear what's happening with the pumps too.

race8k
Dirt Forum Racer

Total posts: 98
posted June 17, 2002 03:13 PM
The pumps are breaking just above where they mount on the narrow part.I have seen them break before but never 2 in 3 weeks.

DodgeBoy76
Dirt Full Roller

Total posts: 73
posted June 18, 2002 12:34 AM
If you have the block decked too much the distributor may be bottoming out on the oil pump drive shaft, I dont know Im just stabbing in the dark at this one, but we had a flat top motor that was decked and the distributor bottomed out, it never broke the oil pump, but the timing would always back off.

ford5
Dirt Freak

Total posts: 298
posted June 18, 2002 07:12 AM
is your oil pan contacting the pump?

sdhnc29
Dirt Freak

Total posts: 467
posted June 18, 2002 10:57 PM
I'd have to agree with a few of the previous post's . It sound's like you have something leveraging the pump , or hitting the pump to break it . Although ..... I have seen big block pump's break exactly where your speaking of , without anything in the engine causing the problem . When our business was in CA , it was very common the wet mag a pump housing , and find it cracked where your speaking of . I think that the cause of this was due to the weight of the pump's , and the extremely rough track condition's that are prevalent in CA .

Steve

------------------
Hendren Racing Engines
Rutherfordton , NC
(828)286-0780

6x
Dirt Roller

Total posts: 24
posted June 22, 2002 08:06 AM
PULL YOUR PAN OFF AGAIN AND START WITH THE REAR MAIN CAP, TAKE IT OFF AND LOOK TO SEE IF ITS BROKEN, IF ITS NOT CHECK EACH ROD CAP, ONE OR MORE IS BROKE, YOUR CRANK IS FLEXING AND BREAKING IT OFF, LET ME KNOW

wingnut
Dirt Full Roller

Total posts: 70
posted July 03, 2002 08:53 PM
i don't know if this is a possibility or not,but we have had this happen a coulple of times.
when you put on the pick up tube do you tap it on with a hammer? if so maybe try to get a looser,but still decent fit and put a small,quick tack weld on it.be careful not to get a lot of weld and heat,to avoid weaking the spring.you could also tap it and use a set ***** with loctite if your not comfortable with tacking it.
again this may not be a cause,but we have had it happen with melling and dynagear pumps. good luck

Back to the Archives