Visit The Dirt Forum for More Information

Author Topic:   chevy 350 into firebird body
One87Racing
Dirt Full Roller

Total posts: 61
posted February 11, 2003 11:44 PM
Anyone besides me trying to or have done this? what is required? the 78 firebird body I got had a pontiac 350 in it when it started life. The mounts that I got for the chevy engine looked the same so I stuffed them in and then went to set the engine in and the mounts seem to be off about 1/2 inch on one side. I got the engine to set in the mounts with some prying and 4 letter words, but the trans mount seems to be off also. What did I do wrong? are the mounts for a 305 and 350 different (i got 305 mounts thinking they were the same)? I'm at a loss so any help would be appreciated. Thanks

Pickel
Dirt Forum Champ
Total posts: 564
posted February 12, 2003 08:35 AM UIN: 25419780
ok lets ee if I rember right lol... the Pontiac block is bigger then the chevy so you need to take the monts lose off the frame and move them back and inwerd (I think) .. the best way would be to take the monts off the frame and bolt the to the motor and then set it in place (with the trany bolted to the block)and then tac weld them in and the pull the motor back out (but take the bolt out first lol) then finish weling the mounts in..jus make sure everything in lined up.

racer17j
Dirt Forum Champ
Total posts: 1565
posted February 12, 2003 09:23 AM UIN: 54865418
the mounts should be the same as long as they are for a car the chevy truck /van mounts don't work in cars they are to tall also if i rember right the pontiac stuff is mounted a little further back on the block. is your tranny to far back to hit the hole or is it off side to side

One87Racing
Dirt Full Roller

Total posts: 61
posted February 12, 2003 10:34 AM
front to back seems ok as the trans mount drops right in it's hole. When I dropped the engine in, I could get one bolt thru, and the other was 1/2 inch off of the hole for the other mount. It needs to go down and in about 1/2 inch and it would be fine. I may end up just pulling the engine back out and re drilling the holes for the mounts unless someone has a quick fix. Thanks.

tilley88
Dirt Freak

Total posts: 353
posted February 12, 2003 11:03 AM
All Firebird/Camaro engine crossmembers should be the same, meaning they should have multiple mounting holes for your frame mounts. Are you sure you have the correct mounts?

SS90
Dirt Roller

Total posts: 13
posted February 12, 2003 09:23 PM
One of the mounts bent maybe?

nate 11
Dirt Full Roller

Total posts: 52
posted February 12, 2003 09:37 PM
ss prying and four letter words LOL

nate 11
Dirt Full Roller

Total posts: 52
posted February 12, 2003 09:39 PM
i hit wrong key on the computer. just do it like pickel said to.

One87Racing
Dirt Full Roller

Total posts: 61
posted February 13, 2003 12:52 PM
I'll try it. Thanks

Back to the Archives