Visit The Dirt Forum for More Information

Author Topic:   belts keep coming off
LUBEGUY07
Dirt Maniac

Total posts: 156
posted April 21, 2002 09:39 AM
i am having trouble throwing my p/s belt off the pump is aligen right and i use new belts with stock pullys should i go with aftermarket pullys. I dindt have this trouble before we switch gears and the cars turns a lot more rpms now . Any advice? thanks alot

LUBEGUY07
Dirt Maniac

Total posts: 156
posted April 21, 2002 09:44 AM
if forgot to say i run a two belt system one for alt and one for p/s both have seperate groves on the water pump pully and crank pully, also iam turn 7000 rpms too


dirtracer17
Dirt Forum Racer

Total posts: 88
posted April 21, 2002 11:58 AM
Find a parts store who sells gates belts.I have never lost one of them yet. I would also use the aftermarket pulleys too.

racer17j
Dirt Forum Champ
Total posts: 1565
posted April 21, 2002 01:29 PM UIN: 54865418
get some pullies and black spray paint

LUBEGUY07
Dirt Maniac

Total posts: 156
posted April 21, 2002 02:13 PM
i have been using gates belts,and 17 j what type of pulleys u sugest, have u raced yet this year

jammin
Dirt Administrator

Total posts: 5556
posted April 21, 2002 02:27 PM UIN: 16262997
Top Gog Dayco belts are great...they wont stretch.

jammin

Scoot
Dirt Freak

Total posts: 330
posted April 21, 2002 09:01 PM
I've heard a large fan can cause this at high RPM's. I personally haven't had this problem though.

------------------
Scoot
Smith Racing Team
870-365-5989

dirtracer17
Dirt Forum Racer

Total posts: 88
posted April 21, 2002 09:34 PM
I have finally lost my mind!! I don't use gates belts, I use the same ones jammin recommends. BOY,GETTING OLD BITES !

[This message has been edited by dirtracer17 (edited April 21, 2002).]

Flatlander
Dirt Freak

Total posts: 310
posted April 21, 2002 10:35 PM
are both belts coming off or just the PS One thing I/ve found is to not over tighten them

racer17j
Dirt Forum Champ
Total posts: 1565
posted April 22, 2002 12:55 AM UIN: 54865418
just get the aluminum ones from midwest and paint them black we aren't suposed to run them but they don't carry a magnet with them so he will never know. and no i haven't been out yet i have done all the work on my car myself this year so it's taking a little longer than i had hoped should be out in a couple weeks white and blue malibu with purlpe and neon orange 17j

racer17j
Dirt Forum Champ
Total posts: 1565
posted April 22, 2002 12:58 AM UIN: 54865418
was that the same guy driving last nite or did he just get a new suit?

te33
Dirt Full Roller

Total posts: 46
posted April 22, 2002 07:25 PM
we had the same problem,who hasn't right?we were try to run one belt around the water pump,and the p/s steering.spit it right off.we put a belt just around the w/p,and the same belt back around the w/p and p/s.stock pulleys,dayco belts.not a problem since.we do however change the belts as a regular mat. item.i figure it was just to much stuff for 1 belt to turn at 7000.

LUBEGUY07
Dirt Maniac

Total posts: 156
posted April 23, 2002 07:43 PM
ok thanks for the advice we are going to try dayco top cogs belts friday night and if they dont work going to try some aftermarket pullys. and 17 j we had Terry Buenting from ftdodge drive it in heat race to help us fix the push it had and man did it work we didnt have enugh rear stagger we changed it and it worked still a litty doggy of the coners but man the thing likes to rev up.I talked to the tech man at britt and he said we could run aftermarket pullys ,see u on the track in a couple weeks


racer17j
Dirt Forum Champ
Total posts: 1565
posted April 24, 2002 01:06 AM UIN: 54865418
so what did you put in it for a gear she was a screamer from up top anyway

LUBEGUY07
Dirt Maniac

Total posts: 156
posted April 24, 2002 08:42 AM
we put 410 in it and tried 225 75 15 and then tried 205 75 15 they worked better


Back to the Archives