Visit The Dirt Forum for More Information

Author Topic:   handling problems
Oldsmobile13
Dirt Full Roller

Total posts: 66
posted August 05, 2001 05:29 PM
I just increased the power of my 355 last week and this weekend my car started pushing and the @$$ end would slide around. This is new for this car and i wonder if I am just overdriving it because it is much faster than usual. I have all Afco springs 1000 lf 1100 rf. The weight is 50-50 front to rear. Stock style shocks on front.

racer2
Dirt Full Roller

Total posts: 29
posted August 05, 2001 07:06 PM
I would wait and see if it does it the next race before you change anything

URDUSTED
Dirt Roller

Total posts: 7
posted August 08, 2001 01:00 AM
USE more brake getting into the corner. The car will set and you can get back onto the gas earlier. Also, found that about 53% to 54% rear weight will help.

Oldsmobile13
Dirt Full Roller

Total posts: 66
posted August 08, 2001 12:49 PM
Do you guys think it would have anything to do with the sway bar on the back because i never took it off? I am going to try a little more camber on the right side and hope it may help. How about less pressure in the left rear tire?

avila
Dirt Roller

Total posts: 12
posted August 09, 2001 03:18 PM
Well, how much faster is your lap time since the engine improvment? This really sounds like a handling problem and now you need to
work on suspension setup.

[This message has been edited by avila (edited August 09, 2001).]

Oldsmobile13
Dirt Full Roller

Total posts: 66
posted August 14, 2001 01:53 AM
The car is much faster with the new engine, I think i may need more body roll for sidebite. What do you think?

Back to the Archives